Индексация веб-страниц и файлов

Справка по созданию WWW, FTP и почтового серверов
в локальной сети

  • Установка и настройка протокола TCP/IP
  • Установка программы Small HTTP server
  • Настройка Internet Explorer
  • Настройка Outlook Express
  • Настройка клиента Asona FTP

2003 г

Леонтьев А.А. Калининская школа


Настройка FTP

Настройка FTP- клиента.

1. Установить Asona FTP на ученических местах.

2. Проверить есть ли файл Hosts (без расширения) в папке Windows. Если такого файла нет, то скопировать файл Hosts.sam из папки Windows в эту же папку и переименовать его в файл Hosts (без расширения).
Этот файл содержит сопоставления IP-адресов именам узлов.
В первом столбце должен находиться IP-адрес учительского компьютера, за ним должно следовать имя ftp-сервера, указанного в сервере, т.е. в программе Small HTTP server. IP-адрес и имя узла должны разделяться хотя бы одним пробелом.
Например:
192.168.0.1 ftp.perm.ru

3. Запустить программу Asona FTP. Нажать Новый сервер.

Заполнить поля Название и FTP Сервер. Название - любое. FTP Сервер - то же имя, что указали в файле Hosts и в настройках сервера, т.е. в программе Small HTTP server. Поставить галочку около поля Анонимное соединение. Сохранить настройки.

4. В панели Локальный компьютер установить директорию, в которую будут скачиваться файлы.

Если сервер на учительском месте установлен, запущен и настроен, то можно работать.


Настройка Internet Explorer

Запускаем Internet Explorer. Щелкаем Сервис / Свойства обозревателя.

На вкладке Общее, в поле Адрес желательно указать домашнюю страницу Вашего сервера, с которой будет начинаться обзор.

Переходим на вкладку Подключение.

Щелкаем кнопку Настройка сети.
Ставим галочку около слов Использовать прокси-сервер, указываем IP адрес учительской машины, на которой установлен сервер (192.168.0.1) и порт (80).
Ставим галочку около слов Не использовать прокси-сервер для локальных адресов.

Нажимаем несколько раз ОК, пока не выйдем из настроек.


Настройка Outlook Express

Запускаем Outlook Express. Щелкаем Сервис / Учетные записи.

Выбираем вкладку Почта.
Нажимаем Добавить.
Выбираем Почта.
Вводим имя, нажимаем Далее.

Отмечаем, что У меня уже есть учетная запись, которую я хочу использовать.
Вписываем адрес электронной почты, нажимаем Далее.

Указываем сервер входящих и исходящих сообщений в числовом виде, ( т.е. IP-адрес учительского компьютера) например 192.168.0.1,
Нажимаем Далее.

(Ленивые и очень занятые данный пункт могут не читать и не выполнять)

Вместо числового имени сервера можно указать доменное имя, например kalinino.kr.ru.

Но в этом случае нужно проверить есть ли файл Hosts (без расширения) в папке Windows. Если такого файла нет, то скопировать файл Hosts.sam из папки Windows в эту же папку и переименовать его в файл Hosts (без расширения).
Этот файл содержит сопоставления IP-адресов именам узлов.
В первом столбце должен находиться IP-адрес учительского компьютера, за ним должно следовать имя почтового сервера, указанного в сервере, т.е. в программе Small HTTP server. IP-адрес и имя узла должны разделяться хотя бы одним пробелом.

Например:
192.168.0.1 kalinino.kr.ru
Указываем имя входа в систему, например pk10, пароль можно не указывать, но галочку около слов Запомнить пароль лучше поставить.
Нажимаем Далее / Готово.

Если не нравиться имя учетной записи, то его можно поменять. Для этого нажать Сервис / Учетные записи, выбрать учетную запись, нажать Свойства и изменить имя учетной записи.


Установка сервера

  1. Установить программу Small HTTP server.
  2. Создать на диске 2 каталога, в которых будет размещаться информация для WWW и FTP. Можно, например, в папке (shttps), где установлен сервер (C:\Program Files\shttps), создать каталоги WWW и FTP, в которые в дальнейшем поместить нужную информацию.
  3. Зарегистрировать программу. Для этого, запустить программу, свернуть появившееся окно, щелкнуть правой кнопкой мыши по иконке в панели задач, выбрать пункт Регистрация и ввести данные для регистрации. Имя регистрации: Гражданин бывшего СНГ
    Код: 31.
  4. Щелкнуть еще раз правой кнопкой мыши по иконке в панели задач, выбрать пункт Настройки.

Вкладка Общие может быть настроена, например, так:

На вкладках DNS, Dinamic IP, Proxy ничего изменять не нужно.

На вкладке FTP нужно:

1. Снять галочку около пункта Запретить FTP сервер (если она установлена).

2. Установить количество одновременно обрабатываемых запросов. Обычно оно равно количеству ученических мест в классе.

На вкладке POP3 нужно:

1. Снять галочку около пункта Запретить POP3 сервер (если она установлена).

2. Установить количество одновременно обрабатываемых запросов.

На вкладке SMTP нужно:

1. Снять галочку около пункта Запретить SMTP сервер (если она установлена).

2. Установить количество одновременно обрабатываемых запросов.

3. Указать имя SMTP сервера.

На вкладке Другое выбрать пункт Пользователи.

Ввести пользователя, например pk2, пароль можно не указывать, выбрать домашний каталог, например, Program Files\shttps (\pk2 можно приписать вручную), установить доступ (для почты обязательно нужно поставить галочки около POP3 и SMTP) и нажать кнопку Добавить. На диске будет создан почтовый ящик для пользователя pk2. Аналогично создать почтовые ящики для остальных рабочих мест.

Для работы с FTP ввести пользователя с именем anonymous, позволить ему Читать FTP и Писать FTP и указать каталог, в котором будут располагаться материалы для FTP пользователей.

Пользователя admin программа добавляет автоматически, предоставляя ему доступ администратора.

В результате должно получиться примерно следующее.

На вкладке Другое выбрать пункт Виртуальные каталоги и хосты.

Ввести имя, которое вы пожелали дать Вашему серверу и указать каталог в котором будет содержаться материал Вашего Web-сервера. Поставить галочку около пункта Добавить в системный хост-файл и нажать кнопку Добавить. Если есть желание или необходимость, то аналогичным образом, можно создать несколько хостов.

На этом настройка сервера закончена.

Теперь нужно каталоги, предназначенные для WWW и FTP серверов наполнить информацией. В нашем случае нужно наполнить информацией каталоги C:\Program Files\shttps\www и C:\Program Files\shttps\ftp.

На WWW сервере, т.е. в каталоге C:\Program Files\shttps\www главная страница должна иметь имя index.htm или index.html.

Для работы почтовым, WWW или FTP серверами нужно, конечно, еще настроить соответствующие программы: Outlook Express, Internet Explorer, Asona FTP или другие подобные им.


Установка и настройка протокола TCP/IP

Установка и настройка сетевого протокола TCP/IP.

Щелкаем по значку Сетевое окружение, используя правую клавишу мыши, и выбираем из контекстного меню пункт Свойства.

Щелкаем Добавить.

Выбираем Протокол, щелкаем Добавить.

Выбираем изготовителя – Microsoft, сетевые протоколы – TCP/IP, щелкаем OK. Происходит установка протокола.

После установки протокола выбираем компонент TCP/IP и щелкаем Свойства.

В появившемся окне выбираем вкладку IP-адрес. Указываем - указать адрес явным образом. Вводим IP-адрес, например 192.168.0.10 и маску подсети 255.255.255.0. Щелкаем OK.

Аналогично нужно установить TCP/IP протокол на всех компьютерах. Лучше использовать адреса:
192.168.0.1 - для учительского места (сервера),
а для ученических мест
192.168.0.2
192.168.0.3
..................
и т.д.

Маска подсети везде одна и та же - 255.255.255.0.

Проверка работы протокола TCP/IP.

Если щелкнуть левой кнопкой мыши по сетевому окружению, то мы должны увидеть все компьютеры сети. Но это еще не означает, что компьютеры общаются с помощью протокола TCP/IP, т.к., наверное, у Вас еще установлен протокол связи NetBEUI, поэтому, чтобы убедиться в работоспособности TCP/IP нужно воспользоваться программой Ping.exe из каталога Windows.
Открываем сеанс MS-DOS (Пуск / Программы / Сеанс MS-DOS).
Пишем ping IP-адрес того компьютера, с которым хотим связаться.
Например: ping 192.168.0.9 и смотрим, есть ответ от запрашиваемого компьютера или нет.

Если все сделано правильно, то ответ должен быть примерно в таком виде.

Если запрашиваемый компьютер не будет найден, то будет соответствующее сообщение об этом.